Photo
- - - - -

mod_security + WordPress = 403 Forbidden?


  • Please log in to reply
5 replies to this topic

#1 manitoba98

manitoba98

    Small Orange

  • Members
  • PipPip
  • 12 posts

Posted 22 July 2006 - 12:52 PM

I get a 403 Forbidden error while trying to post in WordPress. I understand this has to do with the webhost having mod_security. How can I resolve this issue?
  • 0

#2 -ASO- Tim

-ASO- Tim

    Former Head Orange

  • Members
  • PipPipPipPipPipPipPip
  • 5,239 posts

Posted 22 July 2006 - 01:11 PM

What are you trying to post? It's probably hitting one of the keywords, like wget or curl.
  • 0
Former Owner/Manager
timdorr.com

#3 Béranger

Béranger

    Small Orange

  • Members
  • PipPip
  • 44 posts

Posted 22 July 2006 - 01:41 PM

QUOTE
Tim' date='Jul 22 2006, 9:11 PM' post='51835']
What are you trying to post? It's probably hitting one of the keywords, like wget or curl.
*cough* I'm still angry myself. "wget", "perl " or "curl", as dangerous words... ha!
It's like killing people having contagious diseases, just to avoid the danger in case they'll sneeze.
But they might be not sneezing, just passing by.
It's "take it or leave it", however.
I'm still on "take it", coz the service is otherwise good smile.gif
  • 0

#4 Orien

Orien

    Very Large Orange

  • Members
  • PipPipPipPipPip
  • 594 posts

Posted 22 July 2006 - 02:46 PM

Make or edit your wordpress .htaccess.

CODE
<IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

  • 0

#5 manitoba98

manitoba98

    Small Orange

  • Members
  • PipPip
  • 12 posts

Posted 23 July 2006 - 09:49 AM

Well, I was posting a list of software (not including UNIX tools like perl, curl, or wget, though). Something must have triggered it. It seems like mod_security is a bit intrusive. Thanks, Orien, for your help!
  • 0

#6 Orien

Orien

    Very Large Orange

  • Members
  • PipPipPipPipPip
  • 594 posts

Posted 23 July 2006 - 03:38 PM

QUOTE(manitoba98 @ Jul 23 2006, 7:49 AM) View Post

Well, I was posting a list of software (not including UNIX tools like perl, curl, or wget, though). Something must have triggered it. It seems like mod_security is a bit intrusive. Thanks, Orien, for your help!

You're welcome. smile.gif I had the same problem.
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users